Slow Background Jobs

Incident Report for Ovation

Resolved

Performance has been restored, we will continue to monitor.
Posted Dec 11, 2025 - 11:15 EST

Monitoring

We are seeing improved performance across the app and are continuing to monitor.
Posted Dec 10, 2025 - 20:08 EST

Identified

We're currently experiencing delays across Ovation, including workflows and patient reports. We are working urgently to resolve the issue.
Posted Dec 10, 2025 - 16:59 EST
This incident affected: Lab (lab.ovation.io).