Fax Delays

Incident Report for Ovation

Resolved

Our fax provider has released a fix and fax queues are decreasing. We will continue to monitor.
Posted Mar 31, 2026 - 10:09 EDT

Update

Our fax provider is currently investigating an issue causing faxing delays. We are monitoring for updates.
Posted Mar 31, 2026 - 09:07 EDT

Investigating

Our fax provider is currently investigating an issue causing faxing delays. We are monitoring for updates.
Posted Mar 31, 2026 - 09:07 EDT
This incident affected: Lab (lab.ovation.io).