Email notifications not delivered
Incident Report for Ovation
Resolved
We have fixed the issue with our email provider that was causing outbound emails to not be delivered. If you believe you had emails that were affected by this issue and would like to resend them, you can do so using the "resend email" feature where applicable.
Posted Feb 26, 2024 - 23:24 EST
Monitoring
We have fixed the issue with our email provider that was causing outbound emails to not be delivered. If you believe you had emails that were affected by this issue and would like to resend them, you can do so using the "resend email" feature where applicable.
Posted Feb 26, 2024 - 19:42 EST
Investigating
Some email notifications, including those informing providers that patient result reports are ready, were not delivered starting on Feb 21 — and all notifications after Feb 22 — due to an issue with our email provider. We are working on a fix. If any of your providers rely on those emails to know to go to the portal to view reports, you may want to inform them that they should log in to view them.
Posted Feb 26, 2024 - 16:41 EST
This incident affected: Lab (lab.ovation.io).