Delayed Faxes
Incident Report for Ovation
Resolved
The incident causing some outbound faxes to be delayed has been resolved.
Posted Oct 10, 2023 - 16:27 EDT
Identified
Our fax vendor has identified an issue that may cause some outbound faxes to be delayed. They are working on a fix and we will provide updates as we have them.
Posted Oct 10, 2023 - 14:06 EDT
This incident affected: Lab (lab.ovation.io).